WHMCS 7.1.1

Exploit type: Remote Code Execution in third-party PHPMailer library
CVE Numbers: CVE-2016-10033 and CVE-2016-10045

Description

All versions of the third-party PHPMailer library distributed with WHMCS are vulnerable to a remote code execution vulnerability. This is patched in PHPMailer 5.2.20.

At this time we do not believe the deficiency in PHPMailer is exposed in WHMCS due to our own validation of user input. Furthermore, the vulnerability requires being able to pass user input unfiltered to a message’s “from” address, which in WHMCS is only defined within the admin configuration and only accessible to a trusted admin user.

Irrespective of the known protections in the WHMCS product, this CVE represents a serious issue for PHPMailer. Therefore to mitigate any undiscovered risk or risk to 3rd party extensions using PHPMailer directly, we are releasing updates for all versions of WHMCS in active and long term support to provide the latest PHPMailer library version 5.2.21.


Dejá un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *